
 

Themis reporting 
Reporting available in Themis 
Every Themis module contains reports that are specific to that module. Additional reporting options are available 
via the Discoverer Reporting function. The reports to which you have access are defined by the Themis 
responsibilities you have (e.g.: UOM Data Entry enables you to run Financial reports, while UOM Training 
Administrator provides access to reports relating to the Themis Training module). 
 

Submitting a request in Themis 

Submit a request is the term used in Themis when you create/submit a report.  

The navigation path for the Report/Request function will vary depending on the responsibility you have selected. 
For example: if you log in via the UOM Data Entry responsibility you can select Reports > Run, where as if you log 
in via UOM Training Administrator you can select Processes and Reports > Submit Reports. In addition, the 
submit requests function may be accessed via an individual function (such as the General Ledger Reports 
function within Themis Financials).  

Regardless of the navigation path you have used, the sections and fields that display on the Submit Request 
screen will be consistent. 

To submit a request 
1 Log on to Themis and navigate to the Report/Requests function. 

The Submit a New Request screen will display. 
2 Ensure the Single Request option is selected, and click the OK button. 

The Submit Request screen will display. 
3 In the Name field, select the report you wish to run from the List of Values. 

Alternatively, if you know the name of the report, you may type a portion of the report name and press Tab to 
display a list of reports beginning with the value you typed (e.g.: if you type UOM and press Tab, all reports 
beginning with UOM will display). 

4 Enter the appropriate parameters for the selected report and click the OK button. 
Note: The parameters displayed will vary depending on the report you have selected. Compulsory fields will 
be highlighted in yellow. 

5 Click on the Schedule and/or Options buttons and enter appropriate details, if required. 
Refer to the Scheduling a request section below for further details on scheduling reports to run automatically 
and completion options (e.g.: print copies, notification of completion, etc). 

6 Click on the Submit button to run the report. 
The View Request screen will display automatically to show the progress of your request.  

 
• Click on the Refresh Data button to update the progress of your report.  
 
Refer to Viewing your request results section below for details on viewing the report output. 
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Viewing your request results 

Once you have submitted your request/report, the view screen will display automatically. You may also navigate to 
this screen at any time if you wish during your Themis session to retrieve previous report results. 

To view your report results 
1 Select View > Requests from the Menu bar. 

The Find Request screen will display. 
2 Ensure the All My Requests option is selected, and specify the number of days for which you wish to retrieve 

requests. 
Note: Themis will default to retrieve the last 7 days of your requests unless you specify otherwise. 

3 Click on the Find button to retrieve the requests for the period specified. 
The Requests screen will display all reports you have run for the period specified and their status (e.g.: 
completed, etc). 

4 Select the report you would like to view, then click on the View Output button. 
The report results/output will display. 

 
Note: only one results page will display at a time: 
• Use the scroll bars located on the right and bottom of the screen to scroll through the information 

displayed in the active page. 
• Use the buttons located at the bottom of the screen to progress through the available pages (e.g.: Next, 

Previous, Last, etc). 

Printing your request results 

The report/request results will print to your default Themis printer automatically if you have set your Concurrent 
Report Copies to 1 in your Themis profile/preferences.  

However, if you have set your print preference to 0 you will need to print the results manually. Refer to the 
Reprinting your request results section below for further details. 

 

Exporting your request results 

All report/request results and data in Themis may be exported to Excel. 
1 Navigate to your report results/output screen. 

Refer to steps 1 to 4 in the Viewing your request results section above for further details. 
2 Select Tools > Copy File from the Menu bar. 
3 Ensure MS Excel format is specified and click the OK button. 

A File Download dialog box will display, asking whether you wish to Open or Save the results.  
4 Select Open to view the report/request results in an Excel worksheet. 
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Reprinting your request results 

If your print preferences are set to 0, or you wish to print an additional copy of your report results, you can use the 
Reprint function in Themis. 

To reprint your report results 
1 Navigate to the Requests screen and click on the report you wish to reprint. 

Refer to steps 1 to 3 in the Viewing your request results section above for further details. 
2 Select Tools > Reprint/Republish from the Menu bar. 

A Republish and Reprint screen will display. 

 
3 Check the printer and number of copies, and update them if required. 

Note: these fields will default from your profile settings. If you need to enter or update your printer, click on 
the torch icon to search for and select the appropriate printer from the list of values. 

4 Click on the Apply button. 
A confirmation message will display and your results will be sent to your nominated printer. 

 
5 Click OK to close this message. 
 

Resubmitting a request 

The Copy function in the Submit Request screen enables you to resubmit a report you have previously run. 

To resubmit a request 
1 Log on to Themis and navigate to the Report/Requests function. 

The Submit a New Request screen will display. 
2 Ensure the Single Request option is selected, and click the OK button. 

The Submit Request screen will display. 
3 Click on the Copy button located at the top left of the screen. 

A list of reports you have previously submitted will display. 
4 Select the report you wish to re-run, and click the OK button. 

The Submit Request screen will populate with the name and parameter details of the report selected.  
5 Click in the Parameters field and make any changes, if necessary. 
6 Enter any scheduling or output details if required, then click the Submit button to run the report. 

Refer to the Scheduling a request section below for further details. 
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Scheduling a request 

The request scheduling feature in Themis allows you to program reports to run automatically when required (e.g.: 
weekly, monthly, every Tuesday, on the last day of the month, etc). Important: when scheduling a report to run 
automatically, you should only schedule them to run outside of peak usage hours (i.e.: between 8pm and 6am 
nightly or alternatively, on weekends where possible). 

To schedule a request 
1 Log on to Themis and navigate to the Report/Requests function. 

The Submit a New Request screen will display. 
2 Ensure the Single Request option is selected, and click the OK button. 

The Submit Request screen will display. 
3 In the Name field, select the report you wish to schedule. 

Alternatively, if you know the name of the report, you may type a portion of the report name and press Tab to 
display a list of reports beginning with the value you typed (e.g.: if you type UOM and press Tab, all reports 
beginning with UOM will display). 

4 Enter the appropriate parameters for the selected report and click the OK button. 
Note: the parameters displayed will vary depending on the report you have selected. Compulsory fields will 
be highlighted in yellow. 

5 Click on the Schedule button, located in the At these Times section. 
The Schedule screen will display. The default schedule will be As Soon as Possible.  

6 Specify the report schedule required in the Run the Job section of the screen and click OK. 

Schedule option Action Comment 
Once Run the report one time only at the 

date/time specified. 
• Ensure the date/time in the Run At field is 

outside peak hours. 

Periodically  Schedule the report to repeat at 
selected intervals (e.g.: every 5 days, 
1 week, or 1 month) from the 
nominated start date and time.  

• Ensure the date/time in the Start At field is 
outside peak hours.  

• Enter an end date/time in the End At field – do 
not leave this field blank as the report will run 
indefinitely. 

• Specify the interval you wish the report to be 
re-run. 

Specific Schedule the report to repeat on the 
day of the month specified (e.g.: 1st, 
5th, last day, etc) or on the day of the 
week specified (e.g.: Monday, 
Thursday, etc). 

• Ensure the date/time in the Start At field is 
outside peak hours.  

• Enter an end date/time in the End At field – do 
not leave this field blank as the report will run 
indefinitely. 

• Use the calendar to select the date or day you 
wish the report to run. 

• Tick the Save this schedule checkbox if you wish to make the report schedule re-useable for other 
reports. You will need to enter a Name and Description in the Save Schedule screen that displays. 

7 Click on the Options button, located in the Upon Completion section and set your output options. 

Field Action Comment 
Name Enter your name if you would like to 

receive a Worklist Notification when 
the report has been run. 

 

Printer Select your Themis printer from the 
List of Values. 

This field will default from your profile settings but 
may be updated if required. 

Copies Enter 1 if you would like a hardcopy 
of your report to print automatically. 

 

8 Click on the Submit button to queue the report for the scheduled run time. 
Note: if you wish to view the report output, navigate to the Requests screen (refer to Viewing your request 
results section above for further details. 



 

Using the Discoverer reporting functions in Themis 

The Themis Discoverer reporting functions provide users with access to detailed Financial, Human Resources and 
Research reports for their department/organisation unit. The data is presented in a report format which may then 
be manipulated, printed or exported.  

Access to Discoverer reporting is available through a number of different responsibilities: 

• UOM Department (& Below) – Human Resources Discoverer reports 

• UOM Agreements Discoverer Reports – Research (Agreement) Discoverer reports 

• UOM Disco Repts FAC – Finance Discoverer reports  

To run a report 
1 Log on to Themis via the appropriate responsibility and navigate to the Discoverer Reports functions. 

A list of available reports will display. The example below is taken from the HR Discoverer Reporting function. 

 
2 Select the report you wish to run then click on the Expand icon ( ) to display the available worksheets. 

 
3 Click on the worksheet name hyperlink (e.g.: ) to run the query. 

Depending on the report selected, it will either commence running automatically (e.g.: Continuing and Fixed 
Term Staff Listing) or will require you to specify report parameters (e.g.: Increment Details Report). 

If report parameters are required 
Where parameters are required the report parameters screen will display.  Note: the parameters displayed are 
dependent on the report selected. Compulsory parameters are indicated by an . 
4 Specify your report parameters. 

Many of the search parameters allow you to select from a pre-defined list of values. 
• To select from the list of values, click on the Torch icon. The Search and Select screen for the field will 

display.  
• Select the appropriate value/s then click on the Select button to close the screen and return to the report 

parameters. 

 
5 Click on the Go button to run the report. 

The Query Progress screen will automatically update the progress of the report selected. Once the report has 
completed the results will display. 
 
You may manipulate the report results within the Discoverer function (e.g.: reorder columns, use the Page 
Items to group results, sort the results, etc) or export the results to Excel to manipulate.  
For further details on running reports and manipulating or exporting results, refer to the appropriate 
Discoverer Reporting reference cards available on the Themis website. 
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